// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[)([^\]]*)(\])").unwrap();
let string = "I don't [wanna] be a bus [driver] all my [life]";
let substitution = "<b>$2</b>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}