$re = '/\'[^\']*\'(*SKIP)(*F)|\s+/m';
$str = 'dateto:\'2015-10-07 15:05\' xxxx datefrom:\'2015-10-09 15:05\' yyyy asdf';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;