const regex = /^\.\/(?!_exclude\/).*\.vue$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\.\\\/(?!_exclude\\\/).*\\.vue$', 'gm')
const str = `./_exclude/file.vue
./_exclude/file2.vue
./_exclude/svg/globe.vue
./some-file.vue
./svg/cart.vue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}