re = /\b(?!lv)(\w+)\b (?:lv )?(?:d[iy]astolic|distolic) d[iy]sfunction/mi
str = 'Mild LV diastolic dysfunction
Mild diastolic dysfunction'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end