import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\W{3}(\\s|\\s\\s)(“|\")\\W{1,}\\d+\\W+\\d+|(^\\W+:|^.{1,}:)(\\s|\\s\\s)\\W{1,}\\d{1,}\\s\\W{1,}\\d{1,}(\\s|\\s\\s)\\W+)";
final String string = "Сбербанк России ОАО г.Москва\n"
+ "Банк получателя\n"
+ "инн 502204278650\n"
+ "Внимание' Оплата данного счета означает согласие с условиями поставки товара. Уведомление об оплате\n"
+ "обязательно, в противном случае не гарантируется наличие товара на складе товар отпускается пс факту\n"
+ "прихода денег на prc Поставщика. самовывозам, при наличии довереанссти а паспорта\n"
+ "Образец заполнения платежного поручения\n"
+ "70 шт\n"
+ "кпп о\n"
+ "Сч. N?\n"
+ "Сч, N?\n"
+ "044525225\n"
+ "30101810400000000225\n"
+ "40802810740200101005\n"
+ "Краснова Татьяна Валерьевна”\n"
+ "Пол атель\n"
+ "Счет N? 196 от 17.12.08\n"
+ "инн 502204278650 КПП o\n"
+ "Поставщик:\n"
+ "“ИП Краснова Татьяна Валерьевна“\n"
+ "140411, Рф, Моск. обл.,г.Коломна,ул.Зеленая,д.ВА,кв.9\n"
+ "Покупатель: ИНН 5022017021 КПП 502201001 околоменский дом ребенка“\n"
+ "2\n"
+ "Товар\n"
+ "крем ЛАСКОВАЯ МАМА детский л 20мп Москва\n"
+ "Шампунь детский ЛАСКОВАЯ МАМА звомлг•пераое\n"
+ "шение“\" (Москва\n"
+ "КОЛ-ВО\n"
+ "96\n"
+ "Ед.\n"
+ "Цена\n"
+ "Итого:\n"
+ "Сумма\n"
+ "3360 ос\n"
+ "2Ђва 00\n"
+ "6'048.00\n"
+ "Всего наименований 2. на сумму 6048,00 руб.\n"
+ "Шесть тысяч сорок восемь рублей 00 копеек\n"
+ "Руководитель\n"
+ "[Краснова Т.В.}\n"
+ "Бухгалтер\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}