$re = '/\((213|323)\)\d{3}-\d{4}/m';
$str = '(213)123-4567
(323)456-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);