package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([\S]+),[\S]+)`)
var str = `2sf,fs,fs, fsgds,ggygyygydf,sfsdfsdf,fssf ,sdfsdffs fsdf,sdffsf
fhfhfhfhfgh `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}