$re = '/^[PQR](XYZ|ABCD)....[HD].*/m';
$str = 'PXYZ****H*****
QABCD****H*****
AXYG****Z*****
RABCD****H=D*****';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);