// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(dog\S*)|(\S*cat)\b").unwrap();
let string = "dog cat catdog dogcat 1dog file.dog dog.cat dog-cat banana bananacat ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}