package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^@\s]+@[^@\s]+\.[a-z]{2,}$`)
var str = `I want to check email format like
email :
Heythere123@something.com
// passed
but
email:
Heythere123@something.com2222
// should not pass
email:
Heythere123@something.com#$@!
// shuuld not pass`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}