const regex = new RegExp('(http|ftp|https)://([^/\\r\\n]+)(/[^\\r\\n]*)?', 'gs')
const str = `http://www.radsoftware.com.au/web/
http://www.radsoftware.com.au/web/Default.aspx
https://www.radsoftware.com.au
http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}