package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^
(?=(a(?-1)?b)(?!b)) a+
(?=(b(?-1)?c))
(b(?-1)?c)
$`)
var str = `aaabbbbcccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}