$re = '/^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$/m';
$str = '# correct LinkedIn URLs
https://linkedin.com/some_profile
https://www.linkedin.com/some_profile
# optional dot exploit, #1
https://notmylinkedin.com/
# escaping exploit, #2
https://notmylinkedin.com?.linkedin.com/
https://notmylinkedin.com#.linkedin.com/
https://notmylinkedin.com/.linkedin.com/
# subdomain exploit, #1
https://linkedin.com.notmylinkedin.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);