# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|(\/\/.*)"
test_str = ("app.on('activate', function () {\n"
" // On macOS it's common to re-create a window in the app when the\n"
" // dock icon is clicked and there are no other windows open.\n"
" if (mainWindow === null) {\n"
" createWindow() //inline comment\n"
" }\n"
"})\n\n"
"// In this file you can include the rest of your app's specific main process\n"
"// code. You can also put them in separate files and require them here.\n\n"
"/*\n"
"multi line comment\n"
"*/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.