using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(black\n{\n.*\n\s*value\s+)\d+";
string substitution = @"\g<1>30";
string input = @"black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}