use strict;
my $str = 'black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}';
my $regex = qr/(?m)^(black\n{\n.*\n\s*value\s+)\d+/p;
my $subst = '\\g<1>30';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";