# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^(black\n{\n.*\n\s*value\s+)\d+"
test_str = ("black\n"
"{\n"
" part cone;\n"
" value 20;\n"
"}\n"
"yellow\n"
"{\n"
" part wing;\n"
" value 30;\n"
"}")
subst = "\\g<1>30"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.