// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(black\n{\n.*\n\s*value\s+)\d+").unwrap();
let string = "black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}";
let substitution = "\\g<1>30";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}