import re
regex = re.compile(r"^SCHEDULE\b.*(?:\n(?!(?:.*#\/.*E|END)$).*)*\r?\n.*#\/.*E\r?\n[^\S\r\n]*NOP(?:\r?\n(?!END$).*)*\r?\nEND$", flags=re.MULTILINE)
test_str = ("SCHEDULE MANAGER_XA#KAAABBBR \n"
"DESCRIPTION \"Added by default.\"\n"
"ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KAAABBBR\n"
":\n"
"S89AAAABBB1#/XAAA/XCCCDDDD/KA0EG014\n"
" FOLLOWS KABBBCCC3\n\n\n"
"S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTE\n"
" NOP\n"
" FOLLOWS KABBBCCC3\n\n\n"
"S89AAAABBB1#/XAAA/XCCCDDDD/KAHHHTTTTTS\n"
" NOP\n"
" FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE \n\n"
"END\n\n"
"SCHEDULE MANAGER_XA#KBBBCCCR \n"
"DESCRIPTION \"Added by default.\"\n"
"ON RUNCYCLE KAAABBBR VALIDTO 09/24/2021 $RCG KBBBCCCR \n"
":\n"
"S89AAAABBB1#/XBBB/XCCCDDDD/KA0EG014\n"
" FOLLOWS KABBBCCC3\n\n"
"S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTE\n"
" FOLLOWS KABBBCCC3\n\n"
"S89AAAABBB1#/XBBB/XCCCDDDD/KAHHHTTTTTS\n"
" NOP\n"
" FOLLOWS MANAGER_XA#KZZZDDDD.KGGGHHHHHE \n\n"
"END")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")