using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^:]*:){2}(*SKIP)(?!)|:";
string substitution = @"";
string input = @":account_id:12345:6789:Melbourne:Aus
:account_id:98765:43210:Adelaide:Aus";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}