use strict;
my $str = ':account_id:12345:6789:Melbourne:Aus
:account_id:98765:43210:Adelaide:Aus';
my $regex = qr/^(?:[^:]*:){2}(*SKIP)(?!)|:/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";