$re = '/-(START(?:_[^_]+){2,3})_\d+(?=-END)/m';
$str = 'test-START_one_4-END
test-START_one_two_three_4-END
test-START_one_two_4-END
test-START_one_two_three_4-END
test-START_one_two_three_four_4-END
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);