# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\n"
r"\{ # { character\n"
r" (?: # non-capturing group\n"
r" [^{}] # anything that is not a { or }\n"
r" | # OR\n"
r" (?R) # recurses the entire pattern\n"
r" )* # previous group zero or more times\n"
r"\} # } character\n")
test_str = ("This is a funny text about stuff,\n"
"look at this product {\"action\":\"product\",\"options\":{...}}.\n"
"More Text is to come and another JSON string\n"
"{\"action\":\"review\",\"options\":{...}}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.