#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})"
Local $sString = " Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj... " & @CRLF & _
" test ets tets tet We value data since we need it ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")