#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=m)(2|3)"
Local $sString = "superscript" & @CRLF & _
"(?<=m)(2|3)" & @CRLF & _
"®|™" & @CRLF & _
"(?<=\d)(de|ème)" & @CRLF & _
"REF" & @CRLF & _
"\d{6}/(D|T|X)" & @CRLF & _
"REF2" & @CRLF & _
"\d{3}/(D|T|X)" & @CRLF & _
"REF3" & @CRLF & _
"\d{6}(?-)" & @CRLF & _
"VET" & @CRLF & _
"garantie[^\r\n]+jaar" & @CRLF & _
"Fraction" & @CRLF & _
"\b1/2\b" & @CRLF & _
"" & @CRLF & _
"PARQUET STRATIFIE ‘MEGALOFT’" & @CRLF & _
"Différents motifs " & @CRLF & _
"Longueur 1286mm x largeur " & @CRLF & _
"194mm " & @CRLF & _
"10000kcal/u" & @CRLF & _
"25mm2" & @CRLF & _
"10dm3 10dm3/u" & @CRLF & _
"1000m3/u" & @CRLF & _
"850l/u" & @CRLF & _
"1000m3/h" & @CRLF & _
"850l/h" & @CRLF & _
"1,99m2/pak" & @CRLF & _
"1,33m3" & @CRLF & _
"1,25m2" & @CRLF & _
"25kg " & @CRLF & _
"700559/D" & @CRLF & _
"1,59m3/pak" & @CRLF & _
"1,996m2/paquet" & @CRLF & _
"700496-123566-123/D" & @CRLF & _
"1,996m2/paquet" & @CRLF & _
"123566-123/D" & @CRLF & _
"1,99m2 en 199m3/h" & @CRLF & _
"135234-123/D" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Gerst 004729/D" & @CRLF & _
"Schors 058157/D" & @CRLF & _
"Ø 30/60 x H230cm" & @CRLF & _
"Polyester doek 280gr/m2" & @CRLF & _
"Crossover®-ontstekingssysteem" & @CRLF & _
"™ Toelatingsnr: 3001B" & @CRLF & _
"32/38mm slang" & @CRLF & _
"ZANDFILTERKIT 10m3/u" & @CRLF & _
"Debiet 1,2m2/u" & @CRLF & _
"Zinklaag: 180-250gr/m2" & @CRLF & _
"2de handgreep" & @CRLF & _
"2ème poignon" & @CRLF & _
"Garantie 25 jaar" & @CRLF & _
"10 jaar waarborg" & @CRLF & _
"Maaihoogteregeling 20-75mm" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Gerst 004729/D" & @CRLF & _
"Schors 058157/D" & @CRLF & _
"Ø 30/60 x H230cm" & @CRLF & _
"Polyester doek 280gr/m2" & @CRLF & _
"Crossover®-ontstekingssysteem" & @CRLF & _
"™ Toelatingsnr: 3001B" & @CRLF & _
"32/38mm slang" & @CRLF & _
"ZANDFILTERKIT 10m3/u" & @CRLF & _
"Debiet 1,2m2/u" & @CRLF & _
"Zinklaag: 180-250gr/m2" & @CRLF & _
"2de handgreep" & @CRLF & _
"2ème poignon" & @CRLF & _
"garantie 25 jaar" & @CRLF & _
"garantie 25 jaar" & @CRLF & _
"Garantie 25 ans jar" & @CRLF & _
"Jaar Garantie 25 " & @CRLF & _
"25 jaar garantie" & @CRLF & _
"10 jaar waarborg" & @CRLF & _
"Maaihoogteregeling 20-75mm" & @CRLF & _
"1/2" & @CRLF & _
"®" & @CRLF & _
"541358/9/60" & @CRLF & _
"541358-12-12/D" & @CRLF & _
"541358-123-123/D" & @CRLF & _
"541358-1234-1234/D" & @CRLF & _
"541358-12345-12345/D" & @CRLF & _
"541358-123456-123456/D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")