# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([àa] usage de|idéal pour|zone mixte|propice au|doté de|composé (de|d'un)|lot \d{1} :) commerces?"
test_str = ("REGEX_1 = (local commercial|locaux commerciaux)\n\n"
"REGEX_2 = ((activit[eé]s?|entrep[oô]ts?|stockage|d[eé]p[oô]t) (ou|/|et de) commerce)\n\n"
"REGEX_3 = ([àa] usage de|idéal pour|zone mixte|propice au|doté de|composé (de|d'un)|lot \\d{1} :) commerces?\n\n"
"REGEX_NOT =\n"
"(à proximité (commerces|\n"
"commerces? proche|\n"
"commerces? [aà] proximit[ée]| \n"
"[aà] proximit[ée](\\s\\w*)? des? commerces?)\n\n"
"[Encapsuler xxx]\n"
"local commercial\n"
"locaux commerciaux\n"
"activité ou commerce\n"
"d'activité / commerce\n"
"entrepôts/bureaux/commerces\n"
"entrepôt et de commerce\n"
"à usage de commerce\n"
"zone mixte commerces\n"
"idéal pour commerces\n"
"en dépôt ou commerce\n"
"stockage / commerce\n"
"composé d'un commerce\n"
"doté de commerces\n"
"lot 1 : commerce\n"
"propice au commerce\n\n\n"
"[NE PAS TENIR COMPTE]\n"
"à proximité (commerces, restaurants)\n"
"commerces? proche\n"
"commerces? à proximité \n"
"à proximité de commerces?\n"
"à proximité immédiate des commerces?")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.