#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?uU)(<a.*href="#".*>)(.*)(<\/a>)"
Local $sString = "<a href="#" target="_blank"></a>" & @CRLF & _
"<a style="" href="bla-bla-bla">тег, который нужно оставить</a>" & @CRLF & _
"<a href="#"></a>" & @CRLF & _
"<a style="" href="#">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href="bla-bla-bla">тег, который нужно оставить</a>" & @CRLF & _
"<a href="#">Тут текст который нужно оставить, а сам тег а удалить</a>"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)