# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a.*href=\"#\".*>)(.*)(<\/a>)"
test_str = ("<a href=\"#\" target=\"_blank\"></a>\n"
"<a style=\"\" href=\"bla-bla-bla\">тег, который нужно оставить</a>\n"
"<a href=\"#\"></a>\n"
"<a style=\"\" href=\"#\">Тут текст который нужно оставить, а сам тег а удалить</a><a style=\"\" href=\"bla-bla-bla\">тег, который нужно оставить</a>\n"
"<a href=\"#\">Тут текст который нужно оставить, а сам тег а удалить</a>")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.