re = /(?:\G(?!^)|\[)[^][.]*\K\./m
str = '[city.name][city.state][city.mayor][city.mayor.name](city.name)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result