#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!^)(?<!\. )[A-Z][a-z]+"
Local $sString = "This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence." & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)