$re = '/(?<!^)(?<!\. )[A-Z][a-z]+/m';
$str = 'This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;