package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(/v3/assets/)(.*?)(/)(.*?)(/)(.*?)(/.*?)(\?.*?\"|\")`)
var str = `src="https://eu-images.contentstack.com/v3/assets/blt69509c9116440be8/bltef0f9e1a32e09046/6468057000cbe421c7ef59f6/chess-1314359_1280.jpg" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}