#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\sMission world\:\s*(?P<game_map>.*)"
Local $sString = "2022/11/13, 11:52:47 Mission world: cam_lao_nam" & @CRLF & _
"" & @CRLF & _
"2022/11/18, 10:59:17 Mission world: vt7" & @CRLF & _
"" & @CRLF & _
"2022/10/31, 09:46:13 Mission world: Altis" & @CRLF & _
"" & @CRLF & _
"2022/12/04, 13:23:30 Mission world: vn_khe_sanh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")