# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\sMission world\:\s*(?P<game_map>.*)"
test_str = ("2022/11/13, 11:52:47 Mission world: cam_lao_nam\n\n"
"2022/11/18, 10:59:17 Mission world: vt7\n\n"
"2022/10/31, 09:46:13 Mission world: Altis\n\n"
"2022/12/04, 13:23:30 Mission world: vn_khe_sanh")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.