import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Gi.+\\s+(\\d+)";
final String string = "\"- Giảm giá 10790000đ\n"
+ "- PMH gia dụng 9600000đ hoặc Giảm 8000000đ\n"
+ "- Giảm thêm 7% khi mua cùng sản phẩm bất kỳ có giá cao hơn\n"
+ "- Mua 1 số Loa karaoke giảm đến 20%\n"
+ "- Mua kèm ỔN ÁP ROBOT giảm giá 12% (Không áp dụng KM khác)\n"
+ "- Mua kèm Ổn áp tự động 1 pha LiOA DRI giảm giá 12% (Không áp dụng KM khác)\n"
+ "- Tặng Bộ 3 ứng dụng giải trí trên TV\"-";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}