# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Gi.+\s+(\d+)"
test_str = ("\"- Giảm giá 10790000đ\n"
"- PMH gia dụng 9600000đ hoặc Giảm 8000000đ\n"
"- Giảm thêm 7% khi mua cùng sản phẩm bất kỳ có giá cao hơn\n"
"- Mua 1 số Loa karaoke giảm đến 20%\n"
"- Mua kèm ỔN ÁP ROBOT giảm giá 12% (Không áp dụng KM khác)\n"
"- Mua kèm Ổn áp tự động 1 pha LiOA DRI giảm giá 12% (Không áp dụng KM khác)\n"
"- Tặng Bộ 3 ứng dụng giải trí trên TV\"-")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.