$re = '/^(?<Time>\S+\s+\S+)\s+\S+\s+(?<Error_Code>\d+)[^\]]+\]\s+(?<Service_Name>\S+)\:\s+(?<Error_Message>.+)/m';
$str = '2021-11-16 18:33:00.565 ERROR 22 --- [ taskExecutor-1] c.c.p.r.t.r.ErrorCountValidationTasklet : PARTIAL ERRORS: Error Count of XYZ message ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);