$re = '/(?<userid>[^\"]+@[^\"]+)/m';
$str = '01022703
021216
07602381
"1206931120@GSA.GOV"
177
177670
1969412
232789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);