Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)
/
g
Input 1
1
New
const { export1 as alias1 } = require("module-name"); const { export2 as alias2, export3 as alias3 } = require("module-name");
Substitution
$1: $2