re = /\(.*?[0-9]{4}\)/m
str = 'Il était une fois (Perrault, vers 1665), une longue et belle histoire (Moi 2019). Cette citation ne devrait pas matcher (Moi).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end