$re = '/"?([^"{]+)?"?\s*:\s*"([^"]+)?",?/';
$str = '(function() {
\'use strict\';
//some configuration stuff (some other stuff may be insterted)
var translations = angular.module(\'module.translations.languages.enUs\', []);
translations.constant(\'translationsName\', {
"first_label":"first_label_value",
"second_label" : "second_label_value"
//etc
});
}());';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);