package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d{8}(?:,[1-9]\d{8})+$`)
var str = `923456789
123456789,923456789
123456789,923456789,923456489
,923456789
,92345678
9234567d3
023456789,923456789
723456789,92345678,333333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}