# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[,\h]+|\h*(,)(?:\h*,)+\h*|[,\h]+$/$1 /gm;t' <<< "GUWAHATI, TEZPUR, , BAMUNI HILLS, MAHABHAIRAB TEMPLE, AGNIGARH ,
GUWAHATI, TEZPUR , , BAMUNI HILLS,, MAHABHAIRAB TEMPLE, AGNIGARH,
GUWAHATI, , TEZPUR, , BAMUNI HILLS, MAHABHAIRAB TEMPLE, AGNIGARH"