$re = '/^(?\'asset\'02)_(?\'market1\'\w{3,})\/(?\'market2\'\w{3,})_(?\'type\'SE)(?\'offset\'L)_(?\'derivative\'PHY|FUT) (?\'period\'SWS)-(?\'year\'\d{4})-\b(?\'month\'0[4]|1[0])\b/m';
$str = '02_AUT/TTF_H_SEL_PHY SWS-2015-10
02_AUT/TTF_H_SEL_PHY SWS-2016-04
02_GASPOOL_L/GASPOOL_H_SEL_PHY SWS-2015-10
02_GASPOOL_L/GASPOOL_H_SEL_PHY SWS-2016-04';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);