// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'SE)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'SWS)-(?'year'\d{4})-\b(?'month'0[4]|1[0])\b").unwrap();
let string = "02_AUT/TTF_H_SEL_PHY SWS-2015-10
02_AUT/TTF_H_SEL_PHY SWS-2016-04
02_GASPOOL_L/GASPOOL_H_SEL_PHY SWS-2015-10
02_GASPOOL_L/GASPOOL_H_SEL_PHY SWS-2016-04";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}