# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x) # Free spacing mode, to allow comment and better view\n\n"
r"# Matching the first line `i5-2520M` (capture group 1)\n"
r"([^ ]+\s*)(?=CPU\s*@)\n\n"
r"# Matching the first line `2.50GHz` (capture group 2)\n"
r"|(?<=CPU)(\s*@\s*\d+.\d+GHz)\n\n"
r"# Matching the `first word` on the second line. (capture group 3)\n"
r"# The `\s*$` is used to not match empty lines.\n"
r"|(^[^ ]+)(?!(?:.*CPU\s*@)|\s*$) \n\n"
r"# Matching the second line `CPU T2400` (capture group 4)\n"
r"|(?<=CPU)(\s*[^ ]+\s*)(?=@)\n\n"
r"# Matching the second line `1.83GHz` (capture group 5)\n"
r"|\s*(?<=@)(\s*\d+.\d+GHz)")
test_str = ("Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz\n"
"Genuine Intel(R) CPU T2400 @ 1.83GHz\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.