re = /^[+-]?\d*\.*\d+(?:[+*\/-][+-]?\d*\.*\d+)*$/m
str = '-0.548*-7+54
*354*/56-+45
.9+-5
4
-6
4/-5*3434.54354-.0254
0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end