$re = '/box(?!-shadow)/m';
$str = '//selects box only if what comes after is not -shadow
box-sizing
box-shadow
box-shadows
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;