package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)SEQ \d{3,6}`)
var str = `SEQ 123
SEQ 1234
SEQ 12345
SEQ 123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}