package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s{0,3}\d{4}\w{0,1}`)
var str = `0706-F
0335-T
4113-O
8798-L
8798-L
0335B-T`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}